MikroTik 기술정보

MikroTik제품의 기술정보를 공유합니다.

문의사항이 있을 시 이메일 문의를 이용하시기 바랍니다.

이메일 문의

RouterBoard Firmware 자동 업데이트

작성자
tnadmin
작성일
2018-11-05 09:57
조회
21
장비 재부팅시 라우터보드의 펌웨어를 업데이트하는 스크립트 입니다.
*펌웨어 업데이트시 장비 재부팅이됩니다.

Winbox의 System > Script메뉴에서 Add를 통해 Script를 새로 추가합니다.

------------------Script-----------------------
/system routerboard
:if ([get current-firmware] = [get upgrade-firmware]) do={
:log info message="current firmware is latest version";
} else={
:log info message="current firmware is not latest version. It will be upgraded now.";
/system routerboard upgrade
:delay 2s
/system reboot
}
-----------------------------------------

추가 후 System > Scheduler에서 새 Scheduler를 추가합니다. On Event 의 내용은 Script이름을 적어주시면 됩니다.


해당 작업을 끝내셧으면 다음 Package업데이트시 자동으로 Firmware업데이트를 진행하게 됩니다.