MikroTik 기술정보

MikroTik제품의 기술정보를 공유합니다.

문의사항이 있을 시 이메일 문의를 이용하시기 바랍니다.

이메일 문의

RouterOS에서의 VLAN 설정예제

RouterOS
작성자
tnadmin
작성일
2022-07-14 14:12
조회
1303
VLAN설정 방법을 설명하기 위하여, 아래 그림과 같이 MikroTik RouterOS 장비가 배치되어 있을때를(Router/Switch 모두 RouterOS 장비) 가정하고 VLAN설정 방법을(CUI) 설명하고자 합니다.


#Router에 대한 VLAN, inter-VLAN 라우팅 예제
#ether1에 인터넷 연결(dhcp-client)
#ether2는 VLAN10에 대해 untag된 access port
#ether3은 VLAN20에 대해 untag된 access port
#VLAN99는 management용, 실제 포트는 사용하지 않음
#ether4,ether5는 VLAN10, 20, 99에 대한 trunk port
#bridge1상에 VLAN설정, VLAN10, VLAN20, VLAN99에 대한 인터페이스 작성
#VLAN10 인터페이스의 IP : 192.168.10.1/24
#VLAN20 인터페이스의 IP : 192.168.20.1/24
#VLAN99 인터페이스의 IP : 192.168.99.1/24
#192.168.10.0/24, 192.168.20.0/24, 192.168.99.0/24 을 internal이라는 그룹으로 묶어서 NAT의 masquerade에 활용

#브리지작성, 세팅중에는 VLAN 필터링 하지 않는 것을 권장
/interface bridge
add ingress-filtering=no name=bridge1 vlan-filtering=no
#브리지에 ether2~5 포트를 추가, access port로 사용할 포트는 pvid에 untag할 VID를 명기
/interface bridge port
add bridge=bridge1 interface=ether2 pvid=10
add bridge=bridge1 interface=ether3 pvid=20
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
#브리지 VLAN테이블 작성
#VLAN10에 대해서는 ether2에서만 untag, ether3~5, bridge1에 대해서는 tag
#VLAN20에 대해서는 ether3에서만 untag, ether2,ether4~5, bridge1에 대해서는 tag
#VLAN99에 대해서는 ether2~5, bridge1에 대해서 tag
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether2,ether4,ether5 untagged=ether3 vlan-ids=20
add bridge=bridge1 tagged=bridge1,ether3,ether4,ether5 untagged=ether2 vlan-ids=10
add bridge=bridge1 tagged=bridge1,ether2,ether3,ether4,ether5 vlan-ids=99
#각 VLAN 인터페이스 작성
/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
add interface=bridge1 name=vlan99 vlan-id=99
#각 VLAN 인터페이스에 주소 부여
/ip address
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
add address=192.168.99.1/24 interface=vlan99 network=192.168.99.0
#각 VLAN 인터페이스를 바라보는 DHCP 서버 작성, 99는 작성하지 않음
/ip pool
add name=dhcp_pool0 ranges=192.168.10.2-192.168.10.254
add name=dhcp_pool1 ranges=192.168.20.2-192.168.20.254
/ip dhcp-server
add address-pool=dhcp_pool0 interface=vlan10 name=dhcp1
add address-pool=dhcp_pool1 interface=vlan20 name=dhcp2
/ip dhcp-server network
add address=192.168.10.0/24 dns-server=8.8.8.8 gateway=192.168.10.1
add address=192.168.20.0/24 dns-server=8.8.8.8 gateway=192.168.20.1
#192.168.10.0/24, 192.168.20.0/24을 intenal이라는 그룹으로 묶기
/ip firewall address-list
add address=192.168.10.0/24 list=internal
add address=192.168.20.0/24 list=internal
add address=192.168.99.0/24 list=internal
#src주소리스트가 internal이고, 외부로 나가는 트래픽에 대하여 NAT처리
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1 src-address-list=internal
#외부주소는 DHCP 클라이언트 설정
/ip dhcp-client
add interface=ether1
#브리지 VLAN 필터링 활성화
/interface bridge
set bridge1 vlan-filtering=yes


#스위치1설정

#Router에 대한 VLAN, inter-VLAN 라우팅 예제
#ether1은 VLAN10, 20, 99에 대한 trunk port
#ether2, ether3은 VLAN10에 대해 untag된 access port
#ether4, ether5은 VLAN20에 대해 untag된 access port
#VLAN99는 management용, 실제 포트는 사용하지 않음
#bridge1상에 VLAN설정, VLAN10, VLAN20, VLAN99에 대한 인터페이스 작성
#VLAN99 인터페이스의 IP : 192.168.99.2/24

#브리지작성, 세팅중에는 VLAN 필터링 하지 않는 것을 권장
/interface bridge
add ingress-filtering=no name=bridge1 vlan-filtering=no
#브리지에 ether1~5 포트를 추가, access port로 사용할 포트는 pvid에 untag할 VID를 명기
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2 pvid=10
add bridge=bridge1 interface=ether3 pvid=10
add bridge=bridge1 interface=ether4 pvid=20
add bridge=bridge1 interface=ether5 pvid=20
#브리지 VLAN테이블 작성
#VLAN10에 대해서는 ether2,3에서만 untag, ether1, ether4~5, bridge1에 대해서는 tag
#VLAN20에 대해서는 ether4,5에서만 untag, ether1~3, bridge1에 대해서는 tag
#VLAN99에 대해서는 ether1~5, bridge1에 대해서 tag
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether1,ether4,ether5 untagged=ether2,ether3 \
vlan-ids=10
add bridge=bridge1 tagged=bridge1,ether1,ether2,ether3 untagged=ether4,ether5 \
vlan-ids=20
add bridge=bridge1 tagged=bridge1,ether1,ether2,ether3,ether4,ether5 vlan-ids=99
#VLAN99 인터페이스 작성
/interface vlan
add interface=bridge1 name=vlan99 vlan-id=99
#VLAN99 인터페이스에 주소 부여
/ip address
add address=192.168.99.2/24 interface=vlan99 network=192.168.99.0
#게이트웨이 입력
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=192.168.99.1
#DNS서버 입력
/ip dns
set servers=8.8.8.8
#브리지 VLAN 필터링 활성화
/interface bridge
set bridge1 vlan-filtering=yes

#스위치2설정

#Router에 대한 VLAN, inter-VLAN 라우팅 예제
#ether1은 VLAN10, 20, 99에 대한 trunk port
#ether2, ether3은 VLAN10에 대해 untag된 access port
#ether4, ether5은 VLAN20에 대해 untag된 access port
#VLAN99는 management용, 실제 포트는 사용하지 않음
#bridge1상에 VLAN설정, VLAN10, VLAN20, VLAN99에 대한 인터페이스 작성
#VLAN99 인터페이스의 IP : 192.168.99.2/24

#브리지작성, 세팅중에는 VLAN 필터링 하지 않는 것을 권장
/interface bridge
add ingress-filtering=no name=bridge1 vlan-filtering=no
#브리지에 ether1~5 포트를 추가, access port로 사용할 포트는 pvid에 untag할 VID를 명기
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2 pvid=10
add bridge=bridge1 interface=ether3 pvid=10
add bridge=bridge1 interface=ether4 pvid=20
add bridge=bridge1 interface=ether5 pvid=20
#브리지 VLAN테이블 작성
#VLAN10에 대해서는 ether2,3에서만 untag, ether1, ether4~5, bridge1에 대해서는 tag
#VLAN20에 대해서는 ether4,5에서만 untag, ether1~3, bridge1에 대해서는 tag
#VLAN99에 대해서는 ether1~5, bridge1에 대해서 tag
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether1,ether4,ether5 untagged=ether2,ether3 \
vlan-ids=10
add bridge=bridge1 tagged=bridge1,ether1,ether2,ether3 untagged=ether4,ether5 \
vlan-ids=20
add bridge=bridge1 tagged=bridge1,ether1,ether2,ether3,ether4,ether5 vlan-ids=99
#VLAN99 인터페이스 작성
/interface vlan
add interface=bridge1 name=vlan99 vlan-id=99
#VLAN99 인터페이스에 주소 부여
/ip address
add address=192.168.99.3/24 interface=vlan99 network=192.168.99.0
#게이트웨이 입력
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=192.168.99.1
#DNS서버 입력
/ip dns
set servers=8.8.8.8
#브리지 VLAN 필터링 활성화
/interface bridge
set bridge1 vlan-filtering=yes